Phoenix Outage

Incident Report for Path

Update

We are continuing to investigate this issue.
Posted Mar 29, 2025 - 16:24 UTC

Update

We are continuing to investigate this issue.
Posted Jan 30, 2025 - 19:57 UTC

Investigating

We are currently investigating an outage with our Phoenix PoP.
Posted Jan 28, 2025 - 21:25 UTC
This incident affects: North America (Phoenix, United States).