Network outage - Global - LEVEL IMPACT HIGH

Incident Report for Path

Postmortem

While optimizing our edge routers for better performance and routing, we encountered a bug in our edge router controlling software that caused it to drop interfaces configuration on some of our major points of presence (PoPs) following a minor configuration change. This resulted in a loss of access, and we quickly opened remote hands support with our data center partners. The entire team split the work and reverted the bad configuration, and we then rebooted the devices. We apologize for the inconvenience this caused.

Although we had tested the new changes in our test environment and a few small PoPs without any issues, we are currently working internally to build a better testing plan and environment to prevent this type of outage from happening again.

Posted Jul 12, 2023 - 12:16 UTC

Resolved

Remote protection in Frankfurt is now being restored. All POPs are now restored and are operational.
Posted Jul 11, 2023 - 22:28 UTC

Update

Remote protection in Chicago is now being restored.
Posted Jul 11, 2023 - 20:42 UTC

Update

LA2 is now recovered. However there are issues with remote protection in Chicago.
Posted Jul 11, 2023 - 20:00 UTC

Update

Most sites have been restored to full functionality. As of now, the only places with issues are the following.

LA2
Frankfurt - Partial disruption to remote protection.

The team is working to resolve these final issues and monitoring the health of all other sites during this time.
Posted Jul 11, 2023 - 16:41 UTC

Identified

Affected locations currently include:


United States - New York
United States - Silicon Valley
United States - Los Angeles - Coresite
Germany - Frankfurt
Great Britain - London
Singapore - Singapore
Australia - Sydney
Spain - Madrid

Our team is dedicatedly working towards resolving the issue and restoring the network to its fully operational state. We appreciate your patience and understanding during this time.
Posted Jul 11, 2023 - 15:23 UTC

Investigating

We are currently facing significant global routing problems across all Points of Presence (POPs) worldwide. Our team is actively investigating the root cause of this issue in order to resolve it as swiftly as possible. Rest assured that we are dedicated to resolving the situation and will provide updates here as soon as they become available.
Posted Jul 11, 2023 - 14:41 UTC